Allow unsupported CPUs when upgrading/installing ESXi 7.0 (updated 05112020)

Home / Allow unsupported CPUs when upgrading/installing ESXi 7.0 (updated 05112020)

Hi everyone,

Here’s a quick tip for the home lab people with old servers that can’t afford to get new hardware (like me).

It seems like that you can override the installer terminating when an unsupported CPU is detected.

What you need to do, is when booting from the ESXi ISO, press CTRL+O, and type in:

allowLegacyCPU=true

This will allow you to install or upgrade an ESXi 6.7 installation.

I’ve tested this from my server with two X5660s and have no issues so far currently there is an issue where if you run ESXi 7.0 on older hardware, you may not be able to start virtual machines in a nested VM. For example, if you have a Linux VM on an ESXi host VM on the physical host, starting the Linux VM may crash your nested ESXi host. This was an upgrade from 6.7 to 7.0, however, I have not tested this with an upgrade from other 6.x versions to 7.0, please let me know on Twitter and I will update the blog post.

Of course, this is not supported in any way. However, it’s good for us people that can’t afford to buy new hardware with newer CPUs. It means we get to use our old hardware for a bit longer.

Thank you for reading and I hope to see you soon in new blog posts. The blog posts are coming back, with good news to come 🙂

Stay safe and have a great day!

About Author